Hacktank's Forum

Server => Help => Topic started by: MaT on February 14, 2016, 11:06:50 AM



Title: Many bugs regarding the script
Post by: MaT on February 14, 2016, 11:06:50 AM
Greetings, earthlings! It has been a long time since I don't play this game and much less this mod, and oh if that was a hell of a cool mod, no wonder it was my favourite! A couple days ago I thought of coming back to this nostalgic game and saw this huge update of version 1.7.0, it turned out fantastic! I soon started to remind of the many mods I used to play in 4fun servers, despite on default soldat mods. When I reminded of ZRPG I didn't think twice of the idea of creating a ZRPG server to play with my friends and publicly as well, just like I used to play on HT's server.

I've read some troubleshooting posts in this forum and at the soldat forums HT wrote, and it was pretty simple, I got my server running in no time. But when I start the server I get lots of bugs, such as:


  • Some bots that were suppose to be using chainsaws use composite bows instead (when they kill you with the bow, you die and respawn instantly at the same place you died) and the zombie 'Turncoat' uses flamethrower (other zombies might also have the weapons swapped);
  • At the map 'ctf_Growth' the clients disconnect after a short time, it appears on the dedicated server prompt: "<player> could not respond", and shortly before that happens, it says repeatedly on the prompt "<player> is flooding the server" in which the player is actually doing nothing to flood the server, also the jetpack is empty in this map;
  • When I type !help in-game it only shows the commands of how to create and login into the account, the rest information are missing I guess.


Another thing that I noticed is that I downloaded the script files at the soldat forum's post in the 1.9.2 version, but in the files and the in-game intro it says version 1.9.0, is that something I should worry about? I dont know.

If some more bugs come out I list them here. And if you need screenshots or anything else that provides a better insight, I can also do that. Thanks in advance!


Title: Re: Many bugs regarding the script
Post by: Hacktank on February 14, 2016, 08:49:51 PM
Wow, I thought the soldat devs had abandoned it entirely, cant believe a new version was released. And it looks like they made some awesome changes and additions, especially graphics wise. Anyway, it seems like they made some massive, sweeping changes to the scripting system, and they have yet to give any documentation on them. They say that they are going to also add the ability to set specific scripts to not use these features, and instead revert to the older system to fix compatibility issues, but this is not yet available.

Until they either give some documentation or do the other change mentioned theres not much I can do.

Here is what they said in their update announcement verbatim:
Quote
This new Soldat version might introduce some issues with old mods.
We will soon provide a compatibility mod.ini file to fix this,
along with full documentation on how the new modding system works.

And regarding the intro saying 1.9.0, I just forgot to update the .txt file that contains the intro and other messages when I updated the script last. If you want to be sure you are running the latest version of the script you can open the ZRPG.pas file in notepad, and at the top it should say version 1.9.2, last updated september 7, 2015.


SimplePortal 2.3.3 © 2008-2010, SimplePortal